[Japanese]

JVNDB-2012-000026

Janetter vulnerable to information disclosure

Overview

Janetter contains an information disclosure vulnerability.

Janetter is a client software for using Twitter. Janetter contains an information disclosure vulnerability.

Kazuhiko Kusano of Graduate School of Information Sciences, Tohoku University reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

Base Metrics: 4.3 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Medium
  • Authentication: None
  • Confidentiality Impact: Partial
  • Integrity Impact: None
  • Availability Impact: None

Affected Products


Jane, Inc.
  • Janetter for Macintosh versions prior to 3.3.0
  • Janetter for Windows versions prior to 3.3.0.0

Impact

When a malicious page is opened with a web browser while Janetter is being used, session information used to communicate with Twitter may be disclosed.
Solution

[Update the software]
Update to the latest version according to the information provided by the developer.

According to the developer, the Windows version of Janetter contains an automatic update feature. This feature automatically updates Janetter once a day.
Vendor Information

Jane, Inc.
CWE (What is CWE?)

  1. Information Exposure(CWE-200) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2012-0328
References

  1. JVN : JVN#10745573
  2. National Vulnerability Database (NVD) : CVE-2012-0328
Revision History

[2012/03/19]
  Web page was published