[Japanese]

JVNDB-2011-000032

WalRack upload file handilng vulnerability

Overview

WalRack (Walrus File Rack CGI) contains a vulnerability in handling upload files.

WalRack is a CGI that provides an interface to upload files on the Web. WalRack contains a vulnerability in handling upload files.
CVSS Severity (What is CVSS?)

Base Metrics: 6.0 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Medium
  • Authentication: Single Instance
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial

Affected Products


Walrus,Digit.
  • WalRack ver. 1.1.8 and earlier
  • WalRack ver. 2.0.6 and earlier

Impact

An arbitrary PHP script may be executed on the server where WalRack is installed.
Solution

[Update the Software]
Update to the latest version according to the information provided by the vendor.

[Do not use WalRack]
Please discontinue use of WalRack. Refer to the information provided by the developer for more details.
Vendor Information

Walrus,Digit.
CWE (What is CWE?)

  1. Improper Input Validation(CWE-20) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2011-1329
References

  1. JVN : JVN#46984044
  2. National Vulnerability Database (NVD) : CVE-2011-1329
  3. SecurityFocus : 48001
  4. ISS X-Force Database : 67641
Revision History

[2011/05/26]
  Web page published