[Japanese]

JVNDB-2011-000012

Lunascape may insecurely load executable files

Overview

Lunascape may use unsafe methods for determining how to load executables (.exe).

Lunascape is a web browser. Lunascape loads certain executables when using the "script" function. Lunascape contain an issue with the file search path, which may insecurely load executables.

Makoto Shiotsuki reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

Base Metrics: 5.1 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: High
  • Authentication: None
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial

Affected Products


Lunascape
  • Lunascape 6.4.2 and earlier

Impact

An attacker may execute arbitrary code with the privilege of the running application.
Solution

[Update the Software]
Update to the latest version according to the information provided by the developer.

This issue was resolved in Lunascape 6.4.3.
Vendor Information

Lunascape
CWE (What is CWE?)

  1. No Mapping(CWE-Other) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2011-0452
References

  1. JVN : JVN#38362957
  2. National Vulnerability Database (NVD) : CVE-2011-0452
  3. Secunia Advisory : SA43441
  4. ISS X-Force Database : 65592
Revision History

[2011/02/23]
  Web page published