[Japanese]

JVNDB-2010-000049

Multiple Yokka provided products may insecurely load executable files

Overview

Multiple products provided by Yokka may use unsafe methods for determining how to load executables (.exe).

Multiple products provided by Yokka such as text editors, contain an issue with the file search path, which may insecurely load executables.

Makoto Shiotsuki reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

Base Metrics: 5.1 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: High
  • Authentication: None
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial

Affected Products


Yokka
  • DeuxEditor ver1.7.1.2 and earlier
  • NoEditor ver1.33.1.1 and earlier
  • OuiEditor ver1.6.1.1 and earlier
  • SQLEditor8 ver3.8.1.2 and earlier
  • SQLEditorClassic ver1.8.1.3 and earlier
  • SQLEditorTE ver1.9.1.3 and earlier
  • SQLEditorXP ver3.14.1.2 and earlier
  • UnEditor ver1.10.1.2 and earlier

Impact

An attacker may execute arbitrary code with the privilege of running the application.
Solution

[Update the Software]
Update to the latest version according to the information provided by the developer.
Vendor Information

Yokka
CWE (What is CWE?)

  1. No Mapping(CWE-Other) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2010-3165
References

  1. JVN : JVN#07497935
  2. National Vulnerability Database (NVD) : CVE-2010-3165
  3. US-CERT Technical Cyber Security Alert : TA10-238A
Revision History

[2010/10/25]
  Web page published