[Japanese]

JVNDB-2010-000044

Archive Decoder may insecurely load executable files

Overview

Archive Decoder may use unsafe methods for determining how to load executables (.exe).

Archive Decoder is a file extraction software that supports multiple file en extracting files. Archive Decoder contains an issue with the file search path, which may insecurely load executables.

Makoto Shiotsuki reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

Base Metrics: 6.8 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Medium
  • Authentication: None
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial

Affected Products


pon software
  • Archive Decoder Ver.1.23 and earlier

Impact

An attacker may execute arbitrary code with the privilege of running the application.
Solution

[Update the Software]
Update to the latest version according to the information provided by the developer.
Vendor Information

pon software
CWE (What is CWE?)

  1. No Mapping(CWE-Other) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2010-3160
References

  1. JVN : JVN#68536660
  2. National Vulnerability Database (NVD) : CVE-2010-3160
  3. US-CERT Technical Cyber Security Alert : TA10-238A
Revision History

[2010/10/20]
  Web page published