[Japanese]

JVNDB-2008-000075

EC-CUBE vulnerable to SQL injection

Overview

EC-CUBE provided by LOCKON CO.,LTD. contains a SQL injection vulnerability.

EC-CUBE from LOCKON CO.,LTD. is an open source system for creating shopping websites. EC-CUBE contains a SQL injection vulnerability.

This vulnerability is different from JVN#81111541.

An updated version addressing this vulnerability was released on November 7, 2008
CVSS Severity (What is CVSS?)

Base Metrics: 7.5 (High) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Low
  • Authentication: None
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial

Affected Products


LOCKON CO.,LTD
  • EC-CUBE Ver2 Version 2.3.0 and earlier
  • EC-CUBE Ver2 RC Version 2.3.0-rc1 and earlier
  • EC-CUBE Ver1 Version 1.4.7 and earlier
  • EC-CUBE Ver1 Beta Version 1.5.0-beta2 and earlier
  • EC-CUBE Community Edition 1.3.5 and earlier
  • EC-CUBE Community Edition Nightly-Build r17668 and earlier

Impact

A remote attacker could obtain the website administrator's privilege which was created using EC-CUBE.
Solution

[Update the Software]
Apply the latest updates provided by the vendor.
Vendor Information

LOCKON CO.,LTD
CWE (What is CWE?)

  1. SQL Injection(CWE-89) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2008-4991
References

  1. JVN : JVN#19072922
  2. National Vulnerability Database (NVD) : CVE-2008-4991
  3. IPA SECURITY ALERTS : Security Alert for EC-CUBE Vulnerability
  4. IPA SECURITY ALERTS : 200907_ec-cube (Japanese)
  5. JVN iPedia (Japanese) : JVNDB-2008-000075
Revision History

[2008/11/06]
  Web page published
[2009/06/25]
  Overview : Modified "Overview".
  Vendor Information : Added LOCKON CO.,LTD (2008/11/07).